The core of the message :
"If you are currently running CICS/VSE V2.3 and DL/I, you will not be able to do so on z/VSE V4.3. The highest supported z/VSE version and release when running both of these products is z/VSE V4.2.
z/VSE V4.3 also no longer provides product installation support for CICS/VSE V2.3. However, providing that DL/I is not required, IBM will not prohibit you from using CICS/VSE V2.3 with z/VSE V4.3. You will be able to install CICS/VSE V2.3 from an extended base tape supplied with a z/VSE V4.2 or earlier system. Alternatively, the CICS/VSE V2.3 sublibraries will remain in place if a Fast Service Upgrade (FSU) is used to upgrade to z/VSE 4.3. All other z/VSE V4.3 changes will be transparent.
z/VSE-supplied support for a CICS coexistence environment will be removed. However, you will still be able to run CICS/VSE V2.3 and CICS Transaction Server for VSE/ESA (CICS TS) V1.1.1 together on z/VSE V4.3."